yocto_os/sources/meta-tsgrain/recipes-python/schedule/python3-schedule_1.1.0.bb

21 lines
1.1 KiB
BlitzBasic

# Recipe created by recipetool
# This is the basis of a recipe and may need further editing in order to be fully functional.
# (Feel free to remove these comments when editing.)
SUMMARY = "Job scheduling for humans."
HOMEPAGE = "https://github.com/dbader/schedule"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=6400f153491d45ea3459761627ca24b2"
SRC_URI = "https://files.pythonhosted.org/packages/a8/b5/a291a4c0faa491fd5baefa6d89011ece581cff47b23c0a39b42a63383358/schedule-${PV}.tar.gz"
SRC_URI[md5sum] = "9bf7544e37824e450457187633a17b17"
SRC_URI[sha1sum] = "fd1d05a24ce99f8530cf03a7237989280a9d8129"
SRC_URI[sha256sum] = "e6ca13585e62c810e13a08682e0a6a8ad245372e376ba2b8679294f377dfc8e4"
SRC_URI[sha384sum] = "f20415c7a6382fce9c6e2011b3241698a347e7fd5d2eb5b8879f380b92604456939e678df14e60949868d64cc1d97148"
SRC_URI[sha512sum] = "bcfb6202659eba0a0613f68d8b06b9f2ffffce0444e231533932f72b01316b72674208a80418de54630d9b25bb80f1c202061672f7c40ca38020b19a0a51fc3f"
S = "${WORKDIR}/schedule-${PV}"
inherit setuptools3
RDEPENDS_${PN} += "python3-core python3-datetime python3-logging python3-math"