yocto_os/sources/meta-tsgrain-rpi/recipes-core/heartbeat-led/heartbeat-led.bb

19 lines
534 B
BlitzBasic

DESCRIPTION = "Setup gpio led for heartbeat flashing"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
SRC_URI = "file://heartbeat-led.service"
inherit systemd
FILES_${PN} = "${systemd_unitdir}/system/heartbeat-led.service"
do_install() {
install -d ${D}${systemd_unitdir}/system/
install -m 644 ${WORKDIR}/heartbeat-led.service ${D}${systemd_unitdir}/system/
}
SYSTEMD_SERVICE_${PN} = "heartbeat-led.service"
SYSTEMD_AUTO_ENABLE_${PN} = "enable"