yocto_os/sources/meta-tsgrain/recipes-python/flask-wtf/python3-flask-wtf_1.0.0.bb

29 lines
1.5 KiB
BlitzBasic

# Recipe created by recipetool
# This is the basis of a recipe and may need further editing in order to be fully functional.
# (Feel free to remove these comments when editing.)
SUMMARY = "Form rendering, validation, and CSRF protection for Flask with WTForms."
HOMEPAGE = "https://github.com/wtforms/flask-wtf/"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=d98d089889e14b227732d45dac3aacc4"
SRC_URI = "https://files.pythonhosted.org/packages/06/bb/090df80acb1f51ee3996d822ba34096b3e54b3af76c2c46530d6cf35c9b9/Flask-WTF-${PV}.tar.gz"
SRC_URI[md5sum] = "a41a7bef1438c63b2a4d88214812412f"
SRC_URI[sha1sum] = "4b616eb52694832f716e2c24073690d5ca7f8a79"
SRC_URI[sha256sum] = "872fbb17b5888bfc734edbdcf45bc08fb365ca39f69d25dc752465a455517b28"
SRC_URI[sha384sum] = "c82494d3bb9557be4dff372c3437e9e10bd552e5b727777e9d9ed59e87bd01c61731a51aa7bc3a9e0fbaba5966c8f895"
SRC_URI[sha512sum] = "4b47e3586e3fb34f2ef964fb2a84d25c8279d4ce98e2064655e5ecb5f8fd67e4637ffd81b171e4623e2cd943e5abbcb6f5980ea8a354c2745d65c64161c0fd60"
S = "${WORKDIR}/Flask-WTF-${PV}"
inherit setuptools3
# The following configs & dependencies are from setuptools extras_require.
# These dependencies are optional, hence can be controlled via PACKAGECONFIG.
# The upstream names may not correspond exactly to bitbake package names.
#
# Uncomment this line to enable all the optional features.
#PACKAGECONFIG ?= "email"
PACKAGECONFIG[email] = "python3-email-validator"
RDEPENDS_${PN} += "python3-core python3-flask python3-wtforms python3-itsdangerous"