yocto_os/sources/meta-tsgrain/recipes-python/tinydb/python3-tinydb_4.5.2.bb

21 lines
1.1 KiB
BlitzBasic

# Recipe created by recipetool
# This is the basis of a recipe and may need further editing in order to be fully functional.
# (Feel free to remove these comments when editing.)
SUMMARY = "TinyDB is a tiny, document oriented database optimized for your happiness :)"
HOMEPAGE = "https://github.com/msiemens/tinydb"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ee9d91e0565d932659cf275d126c7437"
SRC_URI = "https://files.pythonhosted.org/packages/83/8f/d4d9d4d320d4efb58d723992c32d1384aa6fa685897ee2ee8e90965aba4e/tinydb-${PV}.tar.gz"
SRC_URI[md5sum] = "51b5386f4241e4b0edd10e47f695f323"
SRC_URI[sha1sum] = "937624844159b4ee1e84b2392834dcd01702431c"
SRC_URI[sha256sum] = "7d18b2d0217827c188f177cd23df60e5cd5316a717e836a8e21c8c2488262cf5"
SRC_URI[sha384sum] = "a5fe963204b46f3fa1317c6ad463d20f1f1f54865b4baa2a71ffa2e6dd70feb3934d15b15c9a9e13a74e0ad129cd9123"
SRC_URI[sha512sum] = "219e46cf9a2427bdffc125e922241626653eb16ab570607156e5c041596f8ccce6b1360cadb8d76d33f6c6fa17bd59ca98ce7fa8b840bcaf6c558b635aaf84e6"
S = "${WORKDIR}/tinydb-${PV}"
inherit setuptools3
RDEPENDS_${PN} += "python3-core python3-json"